Where great old Macs live again!

Is this a known issue? I've found one other forum topic on, but no proper idetification of the problem.

Basically, I've a new terabyte Western Digital drive, onto which I installed OS 10.3. When I run Startup Disk, from the OS X installer application running from the CD, I can select the Firewire drive. However, on bootup, the Cube doesn't recognise it. boooo!

So is it something about the Cube specifically? I dunno, I'm lost. I'm about to give up on modernising my Cube.

Also, what's the deal with Firewire Target Disk mode? Can I use it to boot my Cube from my mini mac? or what's that wizard, y'know when you start a Mac for the first time and it says 'Oh let's copy your stuff from an old Mac!'..... how do I get that to run again?

Anyway... thanks for listening to my ramblings.

Views: 600

Reply to This

Replies to This Discussion

I had a Cube with a bad hard drive that would not boot on it's own at first. I could not install an OS via target disk mode because of the hard drive failure. I connected the FireWire drive to the Cube and booted it. I don't remeber if i did so holding the Option key down to be able to choose the FireWire drive. I had Tiger installed on my FireWire drive. Then I was able to use Disk Utility to erase the internal drive (that is how I have gotten a few dead hard drives to work again). Once the hard drive was erased I was able to either install via the Tiger DVD or, in the case of one Cube with a dead optical drive, I used Disk Utility to restore the internal drive from the FireWire drive. The restore took a while but that Cube still works with that install. If you have a quirky install from the restore, you can always reinstall using FireWire target disk mode or with the DVD.
To install regularly via Target Disk Mode, connect your mini and the Cube via FireWire and start up the Cube while holding down the T button and then launch the installer and select the Cube as the destination disk.
I'm at work and using my iPhone right now, but if you have more questions, I can walk thru them tonite when I get home (if we have power, last nite we were without for a while due to Fay).
Hey! An iPhone isn't retro! You're cheating! =P

Heather, I've read your troubles on the Powerbook 5300, so I'll believe you know what you're talking about when it comes to hot-wiring a boot.
I'll read through your post again tonight when I have the machine in front of me. Really appreciate the help.
Target Disk mode doesn't work. The Cube just turns off after 10 seconds of holding the T key.
Opt on startup doesn't allow my to select the firewire drive either.

I *thnk* it may be due to the fact that I'm using a Firewire 800->400 cable? There are no FW400 ports on this drive. I might knick an old Lacie external firewire from my parents and try booting from that.

If that doesn't work, then maybe I'll try putting a different OS on the FW drive; either 9.x or 10.4 Actually, anyone know if the 10.4 installer disk from my PPC mac mini would have the right drivers etc for the Cube? .... probably not.
I didn't even plug a FireWire into my Cube and I just started it up into FireWire Target Disk mode just by starting it up while holding the T key down. Is there a working OS on it now?
I did buy a few extra FireWire cables on eBay once that did not work with any of my FireWire drives or devices. I always use the thick cable that came with my Maxtor FireWire drive. I have a FW MyBook that works well, too.
Mine is a MyBook too... (lol, 'MineBook'). There's no working OS on the drive at the moment. The only OS that'll install on it is OS9. Even when it does install, it reports errors towards the end. It never caused a problem - the OS ran smoothly afterwards. It's only when I try to install OS X or Linux, then the installers cop-out complaining about a dodgey disk.

The worst part about all this? It took my three months to find the tight T-screws so I could take out the drive. On the first turn of the screwdrive I rounded the damn screw head. Disaster. I'll pobably have to drill the damn thing out.

Or, if I can boot from an external drive, perhaps Disk Utility's repair function will help, as you've suggested.
Also, excuse my poor spelling - I'm typing by monitor-light. Ssssh! My spouse is sleeping! I love you, honey! See what you've reduced me to!? Tinkering with all my toys in the dark while you sleep!
Cube Three had the bad hard drive and the broken optical drive. That's the one I mentioned in the first reply. I forgot to say that when I used Disk Utility to do an erase of the disk, I used the extra option of writing zeros to the disk so it really got a good thorough going over. Unfortunately, it has a shattered top on its acrylic case (UPS had fun with a poorly packed box) so it's my only computer that is not connected (to display, keyboard, mouse, power, ethernet etc) and ready to use.
Cube One had a loud hard drive. I got it a new hard drive on eBay that turned out to be bad. I was able to get it running using the same method of booting via FW drive and erasing it (extra zeros, too) with Disk Utility. Then I installed Tiger with my Tiger DVD. The hard drive failed within a week, so I replaced it again with a good hard drive purchased on eBay and repeated my steps. It is working flawlessly to this day.
My eMac, however, had the same issues and it worked perfectly for about six months but after that it began to do random shut downs from time to time. It's not the hard drive though, as it shuts down even when I boot it from the FW drive. Oh well, it only cost $27 and I picked it up locally so no shipping charges.

With no functioning OS installed on the internal drive, FW TDM will NOT work, thus my Erase/Restore method.
Do you have OS 9 on CD? If you do, try booting from the CD and then use Disk Utility to erase (with zeros) the internal drive. (If OS 9 has that option.) Then reinstall OS 9 and see how it goes.
Good Luck with the screws!! A Cube is too cool not to save, though!! Aside from the screw issue you're facing, the Cube is so nice to work on because of the easy access to everything.
Wow. You're a Cube master, I guess. Yeah, I'll stick OS 9 on it. Funny, I ran Disk Utility from the install CD, but it didn't even show / recognise the internal drive. Not good, I guess. Maybe it's shagged altogether.

Still, I really appreciate your help on this. I'll keep h4x1ng away and let you know.
Actually, Heather... if it's not too much trouble, and, really, please don't go out of your way to do this... could you send me a snap of the jumper configuration on the hard drive? I'm just wondering now if I fiddled with mine in the past and have the wrong one. i thought I had a diagram somewhere detailing the correct one, but, can't find it. And of course, I can't get the drive out either to look at the diagram on the drive label!

Anyway, if you know the config, that'd be great.
I printed this pdf when I did all of this the first time. Step 14 on page 6 is the one you want to read. Here's the link for the pdf:
Mine are set to MASTER as I have not upgraded my optical drives.




© 2020   Created by James.   Powered by

Badges  |  Report an Issue  |  Terms of Service