RetroMacCast

Where great old Macs live again!

My New Challenge: Setting Up A BBS Using Mansion BBS Software

Now that I have had my Hermes II BBS -- as well as my old Hotline server -- running quite smoothly for over three weeks now using SheepShaver on my iMac running Yosemite 10.10, I am considering taking up a new challenge.

I don't know what it is with me, but I love going on Internet scavenger hunts looking for very old, hard-to-find, vintage software from 20 to 25 years ago. My gosh! Back then, Photoshop was called SuperPaint, and Adobe was called Aldus? Did you know that?

Anyway, as I said, some of this stuff is extremely difficult to find, if it can be found at all. This is particularly true in the case of some of the original Macintosh-based BBS software packages. I am talking about some of the very earliest ones.

I have already got a number of them available on my Hermes II BBS, as well as on my Hotline server. But one of the few BBS packages which has evaded me for a very long time is called Mansion BBS. I looked high and low for it on the web a number of times, but without success.

However, just a few days ago, I finally found that bugger hiding in a particular place. Nope! I'm not tellin' you where! :)

I think that I have all of the necessary parts of the package . . . at least I am hoping so. If so, I may give it a whirl during the next few days. I don't think that the Mansion BBS software ever used the TCP/IP protocol, or was made telnet-accessible. I think it may just use serial ports, and be a dial-up package. I am not absolutely certain about this yet, but I guess I will soon find out.

"Why are you doing this?" you may ask.

Well, just because I can! :)

But there is another reason. Just imagine if I can get the Mansion BBS software working and set up properly. I will probably be the only SysOp in the entire world who is running the Mansion software. See. So I can boast and beat my chest about it!

Just joking, folks . . . Well, maybe. :)

Views: 116

Reply to This

Replies to This Discussion

I'm always very interested in following this sort of thing. Keep us updated! :)

Hello Chris. Actually, setting up the Mansion BBS software did not work out so well.

After following the instructions that were included with the software -- you have to set proper file paths in a few of the setup files -- I tried to run Mansion BBS. In fact, I tried several times and got the same results.

Double-clicking the program icon resulted in an error 57 -- not -57 -- appearing on my screen, along with another string which I cannot remember now, which pointed to 000046, or some similar number.

As I mentioned before, from what I can tell, Mansion BBS is a dial-up BBS only which requires old style serial ports, -- modem port / printer port -- which this iMac obviously does not have.

I am not really certain about this, because I didn't take the time to look too deeply into the matter, but maybe the BBS failed to launch because it detected that there were no serial ports.

It may also be that it simply cannot run on Mac OS 9.0.4, which is what I am running in SheepShaver with my Hermes II BBS and my Hotline server.

Hm. I can't say I have any experience as a SysOp, so I can't help with anything too technical there, unfortunately. Do you have vintage hardware you try it on directly versus emulation? I never had much luck with MacOS emulators aside from the most basic game playing. 

Hello Chris. I apologize for the late response. However, I don't recall ever receiving an email notification of your reply, even though I pretty much have everything checked in my preferences on this forum.

Anyway, no, I don't have any legacy hardware here, so anything I do with old software -- including the Hermes II BBS software, the Mansion BBS software, or anything else related to the 68k/PPC environment, must be done via an emulator such as SheepShaver or Basilisk II.

Actually though, SheepShaver has been running quite well on this iMac under Yosemite. I only use it to run my Hermes II BBS and my Hotline server, but I have had no major issues with either one, that I am aware of.

Now if I could just figure out why I am not receiving email responses here. I think I will start a new topic and see what happens with that.

RSS

Badge

Loading…

© 2018   Created by James.   Powered by

Badges  |  Report an Issue  |  Terms of Service