Where great old Macs live again!

Hey RetroMacCasters,

I have a problem with my good old companion, an iMac 400 Mhz DV/SE. It still had the original 10 GB harddisk inside which has become conspicuously loud lately. So I finally decided to exchange it with a 40 GB Western Digital HDD, which was used for a Windows XP computer before. The operation itself went well, the hard disk was replaced with no problem and is comfortably quiet now.

However, when trying to fire the iMac back up again and inserting the original OS 9 installation disk for formatting the drive/installation it would start to read the disc - but eventually freeze up. It also freezes when using the hardware diagnosis CD I got with the iMac. Whatever I do, it keeps freezing up after a couple of minutes. Interestingly, the time periods between start-up and freeze vary each time.

So my first suggestion was that maybe the RAM became bad for whatever reason, so I tried to start up with only one of the 256 MB Rams and even tried an older 64 MB RAM - but with no success. The results were the same.

I'm lost now. To be honest, I'm a bit afraid it could be the logicboard. :-(

Anyone else has any suggestions? I'm grateful for any advices ..

Views: 655

Reply to This

Replies to This Discussion

Ok, I finally found it. I'm quoting LEM here...

"If you have a hard drive larger than 8 GB, you should partition is so that the first partition is under 8 GB in size (for simplicity, we suggest 7 GB). Failure to do this could eventually result in an unbootable computer, as all System files must be within the first 8 GB of drive space. These Macs can work successfully with larger drives for some time, but once a System files goes outside of the first 8 GB of space, you'll have nothing but problems."

My hunch is you need a hard drive with a partition UNDER 8 GB while using OS 9. I had the same problem with my B&W G3 a while back. It wouldn't load OS 9 on a larger drive so I just put the boot drive on a smaller drive and partitioned any additional drives.
Hm, my G3/350 b/w runs its 10.4.11 off of a 60 GB without problems.
The LEM or the '' do not know everything - how should they ?
There are so many Mac-models, with different drives and RAM configuration.
You should be able to format the HD when booting from the restore CD using the utilities. The fact that your machine freezes when using the CD is a strong indicator of a hardware malfunction. I do have a spare DV logic board if you need it.
Ken could be right but my B&W G3 would freeze during installs and formats simply because the drive was too large.
oh really? I thought that goes only for the old beige G3 Macs or the b/w G3? As far as I know, the later iMac G3s with OS 9 support up to 128 GB. And the iMac G3 came with a 10 GB harddisk out of the box. If he couldn't boot from HDDs larger than 8 GB, he would have never started up, right ? ;)

I also fear it could be a hardware malfunction, Ken. Too bad. Thanks for your offer, but I suppose that since I'm located in Germany shipping costs would be equally to buying another used working iMac G3 off ebay here.

Anyway, thanks to both of you for your help, appreciate it. :)
Schade, dass du so weit von mir wohnst. Ich würde es dir kostenlos schenken werden. :P
Hmm, update the firmware to 4.19f1 if you havn't already.. there was an issue with large WD drives and old firmware if I remember correctly. But I would recommend doing the firmware from another HD as if the computer crashes while doing the update you would be in bother..

Additionally, ensure your jumpers on the drive are set correctly. I think master rather the CS on these. These logics boards are hardy, changing a hard drive wouldn't kill it..

Have you tried putting back in the 10GB and testing for freezing?

It could be a bad down convertor board, and the 40GB is pulling to much power causing the freeze, but the 10GB was OK
Hi folks,

I followed your advice to put the old 10 GB harddisk in again. (actually it's a 12 GB hdd I found out). Well guess what, I'm writing these lines here from the iMac G3 running OS 9.2.2. Just downloaded Classilla Browser, everything works like a charm for 14 minutes now... I'll let it run a couple of minutes more to check whether this is only a temporal recovery.

Anyway, the noises of these old harddisks is sooooooo annoying!! Incredible - how were we able to work on these machines for hours back in the days? ;-) Lucky enough; I got my hands on a 40 GB harddisk. I'll put this one in later. Let's cross finger it'll work.
wohooo... Odd things going on here. Exactly five minutes after my above posting the iMac freezed up again. I decided to get rid of the old 12 GB HDD and started the operation. It went very well, the new 40 GB HDD is connected and is so calm.

However, new problems occur. The hard disk has no data on it. I inserted the OS 9 disc that came with my iMac and started to boot it up by pressing "C" while booting. Unfortunately it wouldn't react to that and instead shows me the question mark. Alright. Maybe the disc is gone? So I took another OS 9 disc (this time a 9.2.1 retail). But same story, it won't boot. I tried to hold down the mouse button while booting so that he'll eject the disc. Instead he now booted into open firmware (?) and developed a life by giving out the error

"DEFAULT CATCH!", code=100 at %SRR0: ff80b648 %SRR1: 0000b030"

every few seconds. Strange enough I can't even type in any commands there. This is really bizarre. Anyone ever experienced something like this?
Mac os 9
You have to start with cd 9.04
all the others are updates

is the HD mac formatted? HFS ?
Alright. I could have sworn it was set to Master. However, frustrated over the odd reaction I opened the system once again and found the hard disk jumpers were set on slave. Damn! One should always double check before reassembling everything, saves precious time :-)

@applefreak no there were indeed different retail versions of OS 9...
My WesternDigital experiences were not the best either. But they must have served for a few years.
They are relatively loud and tend to hang, I had to throw a 40GB away.
It was not partitioned and worked for a while in a 5400.

I am in Germany, too.




© 2021   Created by James.   Powered by

Badges  |  Report an Issue  |  Terms of Service